1. Home
  2. >>
  3. iphone
  4. >>
  5. The official PostePay application is updated to version 1.4 optimizing for iPhone 5

The official PostePay application is updated to version 1.4 optimizing for iPhone 5



The official PostePay application is updated to version 1.4 optimizing for iPhone 5


In these hours, the application of PostePay received an update coming to version 1.4 and optimizing itself for iPhone 5.

Here are all the news of this new version:

PostePay is compatible with iPhone 3GS, iPhone 4, iPhone 4S, iPhone 5, iPod touch (3rd generation), iPod touch (4th generation), iPod touch (5th generation) and iPad. Requires iOS 4.3.5 or later. This app is optimized for iPhone 5.